USB Kabel aufdrösseln um Schalter einzubauen

bei dem Tonuino Set ist kein Kabel dabei.

Beim Arduino nano mit USB Kabel von AZ-Delivery ist eines dabei.

Hallo zusammen,

wir haben den Schalter-Einbau aus Frust nochmal verschoben und uns heute nochmal ans basteln gemacht. :slight_smile:

Irgendwie bekommen wir die Lampe nach wie vor nicht zum leuchten. Haben bereits alle drei Kabel durchtrennt und überall den Schalter getestet. Die Lampe auf dem Arduino leuchtet bei jedem Versuch nur die Lampe des Schalters leider nicht.

Jetzt hat mein Sohn es grade nochmal versucht und war ganz begeistert, dass er die Lampe zum leuchten gebracht hat. Er hat allerdings die roten Kabelenden versehentlich an silber und gold angeschlossen. :thinking:

Kann es sein, dass der Schalter warum auch immer farblich (silber/gold) falsch eingefärbt ist? Sind irgendwie etwas verwundert darüber. :smiley:
Kann mir das evtl. jemand erklären?

Vielen Dank schonmal für eure Hilfe.

Also meine Konstruktion, die ich oben dokumentiert habe ist gerade durch eine herausrfallende Powerbank komplett abgerissen… Daher habe ich vor der Reparatur Mal so probiert wie du sagtest… bei mir leuchtet da nix…

Den Schalter gab es doch im Set mit unterschiedlich farbigen LED s… probier doch testweise einen andern

Hmm, meine Kabel sehen leider so aus. Irgendeine Idee wie ich da weitermachen könnte?


Edit: ha ha! Tiefer schneiden, ok.

Das silbere ist der Schirm.Also die Abschirmung für das Kabel.Die Litzen sind Netzartig drum herum um die eigentlichen Adern. Wenn du den Schirm vorsichtig aufdröselst,dann legst du die Adern frei.Theoretisch kannst du den Schirm auch durchtrennen,da bei den kleinen,eigenständigen Kisten nicht mit Einstreuungen zu rechnen ist.

1 Like

Ich hole den Thread noch Mal hoch.

Ich habe noch eine weitere Box mit dem Schalter gebaut und identisch verkabelt, also die silbernen Anschlüsse mit + und den goldenen auf GND. Funktioniert. Jetzt baue ich die 3. Box und bei der leuchtet die LED mit der Verkabelung nicht… habe 2 Schalter aus der ursprünglichen 4er Pack Bestellung übrig und probiert…

Vielleicht sind die LED kaputt aber mich iritiert, dass es bei Stenchen79 mit anderer Verkabelung geklappt haben soll… kann man die LED irgendwie testen?

Zusatzinfo… bei einem schalter war der goldene nicht GND… Und ein USB Kabel war nicht das rote, sondern das Schwarze Kabel plus. Klärt sich alles auf :wink:

habe jetzt vom az delivery kabel das schwarze auf die silbernen pins angelötet und ein weiteres mit gnd auf der platine verbunden. die led des schalters leuchtet leider nicht auf, ich kann aber den arduino und die powerbank mit dem schalter trotzdem schalten.

leuchtet die led des schalters nicht, weil das schwarze kabel ggf. masse ist? mich wundert es das der ardunio sich dann trotzdem ein- und ausschalten lässt.

Du kannst auch die Masse unterbrechen, um ein Gerät auszuschalten. D. h. deine Annahme ist vermutlich richtig. In meinem VW-Bus wird auch vieles über die Masse geschaltet und die + Leitungen hängen an Dauerplus. Musste ich auch erstmal drauf kommen :stuck_out_tongue:

Moin,
Da man für den Schalter eigentlich keine Datenkabel benötigt, sondern wirklich nur Strom (5V und GND) nutze ich meistens USB-Steckverbinder mit Schraubanschluss… kosten ca. 5-6€ das Stück also 11€ das paar. Dann die entsprechenden Kabel ran, und fertig. Da kann dann nix mehr schief gehen und man kann die Kabel genau so lang machen, wie man meint, sie zu brauchen um sie dann nochmal länger zu machen, weil man zu viel abgeschnitten hat…

https://www.voelkner.de/products/998549/TRU-Components-USB-Steckverbinder-mit-Schraubanschluss-Stecker-gerade-LT-USB4M-USB-Stecker-Typ-A-Inhalt-1St..html?ref=43&gclid=EAIaIQobChMI2rPj89XI4wIVx6MYCh1A8ABXEAQYASABEgJcjvD_BwE

Den Schalter setze ich dann einfach in die 5V Seite und fertig.

Grüße und ich hoffe, es hilft vielleicht.