Lautstärke über Drehregler ?


#41

@minnie ja kannst du. Mein Ansatz war auch so wenig wie möglich an der Firmware zu ändern.
Ich würde dir aber raten, anstatt nur den Drehpoti zu nehmen, dass du einen PAM8403 Verstärker mit Drehpoti nimmst. Siehe Lautstärke über Drehregler ?
Ich habe zwar die Lautstärkefunktion in der Firmware deaktiviert, aber das ist für die Funktion des Drehpotis nicht nötig.
Es kann sein, dass du die Startlautstärke in der Firmware anpassen/erhöhen musst.
mp3.setVolume(15);


#42

@skss Dankeschön für die schnelle Anwort.:blush:
Dann werde ich mal das Drehpoti bestellen.


#43

Hab das Ding auch angeschlossen. Da kommt schon mächtig was raus.
Sollte man nichtg unterschätzen was 3Watt können.
Allerdings ist meine Grundlautstärke beim einschalten zu niedrig, verschenke quasi Lautstärke.
D.h. ich muss erst noch die Lautstärke per Knopfdruck erhöhen, damit richtig was rauskommt.
Auch dafür verändere ich in der Firmware auch diesen Wert, oder?
mp3.setVolume(15);
Was ist Maxima ? 100 oder 255 ?
Weiss das jemand aus dem Stehgreif, bevor ich im MP3 Player manual nachschauen muss


#44

Der Max Wert ist 30. Würde mich langsam steigern


#45

Super. Danke für die schnelle Info.
Ok dann versuch ich es mit 28 :wink:
Hab ja ne ganz vernünftige Box dran.


#46

@skss: Hi, an welchen Stellen muss ich denn den Verstärker PAM8403 an thorstens Platine anschließen. Ich steig durch die Schaltpläne leider nicht durch… Kann mir da jemand helfen?


#47

Der Verstärker wird schwischen Player und Lautsprecher angeschlossen.
Den Strom kannst du dir entweder vom Player oder vom 5V vom Arduino holen.
Gnd und VCC bzw 5V kannst du mehrfach benutzen.


#48

Danke . Auf der Platine vom Battery Shield sind auch 3x 5V/GND Anschlüsse. Kann ich einen davon nutzen? Oder muss das vom Nano sein?


#49

Sollte auch gehen denke ich.


#50

Das geht ohne Probleme, aber diese Leitungen werden nicht über den Ein/Aus Schalter vom Batteryshield getrennt. Die sind immer an. Wenn du den Schalter eh nicht nutzt, kein Problem.


#51

Wenn ich am Shield dann zwei 5V\Gnd nutze, einem für power für den Nano und einmal für Verstärker, muss ich dann auch beide gnd über meinen an/aus Knopf führen? Bisher habe ich nur den für power für den Nano an meinem Knopf…


#52

Ich bin kein Elektriker, aber nach meinem Verständnis könntest du die 5v und GND auch erst hinter dem Schalter splitten, dann kannst du beides auf einmal an, bzw ausschalten. Ob der Strom jetzt für beide Geräte von eine PIN Paar kommt oder von zwei PIN Paaren macht meines Wissens nach keinen Unterschied.


#53

hast du die Platine von Thorsten im Einsatz, oder alles frei verkabelt?

Ich hab auch den 2x3Watt Verstärker mit Poti verbaut und hab Störgeräusche beim abspielen.
Pause ist OK bis auf leichtes fiepen. Aber sobald im Play Modus “pulsiert” es mit was in leisen Passagen störend ist.
Bei Musik juckt es nicht.
Hab über DAC L/R angeschlossen. Testweise über SPK. Macht keinen Unterschied.
Konnte bisher den internen Verstärker noch nicht testen, weil ich aktuell nicht rankomme ohne alles komplett auseinander nehmen zu müssen. Würde auch gerne den Stereo Modus und vor allem den Drehpoti beibehalten wollen.

Irgendwo hatte ich gelesen für den MP3 Player einen Extra Stromkreis zu legen… wäre halt natürlich doof, da es die Einfachheit der Platine zunichte macht.

Wie ist as bei Euch, die einen Verstärker einsetzen?


#54

Ich benutze die Platine von Thorsten und hatte zuerst den PAM8403 angeschlossen, derzeit aber wieder entfernt, da es ebenfalls ein sehr lautes summen gab.
Desweiteren konnte ich auch keinen Unterschied der Leistung/Lautstärke feststellen.
Gruss


#55

Okay danke für die Rückmeldung. Dann probier ich da ein wenig rum. Gibt ja ein paar Ansatzpunkte.
Ich will halt unbedingt einen Poti…
Problem kommt aber, soweit ich das verstanden habe, eher vom Player, als vom Verstärker.


#56

Hallo, hat hier jemand schon ne praktikable Lösung bzgl eines Verstärkers? Ich musste meinen wieder abklemmen, da die Störgeräusche zu stark waren.


#57

Ich hab jetzt mal einen 2x20Watt Oschi aus China bestellt. Wird wohl noch ne Weile dauern bis der eintrudelt.
Werde dann berichten.


#58

Wenn du den Poti vom Verstärker auf “aus” drehst, sprich er rastet hörbar ein in Stellung null, kannst du danach dann einfach eine Karte rauflegen und die wird dann erkannt?

Bei mir ist der Fall so: Karten nacheinander auflegen, alles geht wunderbar. Schalte ich aber den Verstärker komplett aus, dann akzeptiert der RFID Leser keine Karten mehr :thinking:


#59

Müsste ich nochmal explizit testen, aber ich glaube das geht bei mir problemlos.
Du musst dann den Arduino neu starten?


#60

ja, ganz genau.

ich habe nämlich ausgeschaltet um das Brummen zu unterbinden. Dann habe ich weitere Karten testen wollen, aber da ist nichts passiert