Fehler com error 06


#21

Ich kann wirklich alle Dateien Abspielen…in der Konsole kommt dann “nextTrack()”
den mp3- und advert-Ordner hab ich von github übernommen.
die erste Datei sieht wie folgt aus 0001.mp3

Ich habe gerade eine zweite Karte versucht - leider das gleiche Problem


#22

Ist Deine SD-Karte max. 32 GB groß?
siehe auch:


#23

@dennis: das ist mir noch gar nicht aufgefallen. Genau so verhält sich meinTonuino.

Bei mir liegt es aber nicht an der Kartengröße
ich habe zwei 16GB und eine 2GB Karte versucht.Am Anfang dachte ich, er spielt nur den ADVERT-Ordner nicht ab. Aber die Meldung, dass die Karte verknüpft wurde kommt. Case sensitive ist es nicht, die Schreibweise der Ordner ist egal. Die 1.01 der DFPlayer Bibilothek bringt auch keine Lösung


#24

Was meinst Du genau?

Diese Verknüpfungs-Ansage liegt aber im MP3-Ordner.


#25

Beim Karte Auflegen kommt nicht die Meldung einer neuen Karte. Beim Betätigen der Vor-Taste kommt “1”…der Text “die Karte wurde verknüpft” kommt auch. Aber z.B. die Ansagen des Adminmenü kommen nicht.
Ich hatte gelesen, dass bei FAT die Reihenfolge, wann die Dateien Kopiert werden wichtig ist. Darauf hin habe ich das Tool FATsorter ausprobiert - leider ohne erfolg

Entschuldige bitte, mein Fehler


#26

Hört sich so an als hättest du auch ein exemplar das wirklich nur Zahlen im Dateinamen zulässt, versuche mal die Texte hinter den Zahlen zu entfernen. Vielleicht kommen dann die Ansagen.


#27

Längere Dateinamen (auch mit Namen) scheinen nicht das Problem zu sein. Ich vermute eher die Lücken zwischen den Dateinamen im mp3-Ordner. Ich habe jetzt 999 mp3-Dateien im Ordner abgelegt. Der Fehler Error 6 kommt nicht mehr. Aber anstatt Adminmenü sagt er mir etwas anderes.
Die Bezeichnung des Chips ist JC AA1838CJ691F.1-94

Ich glaube ich bestell einfach einen neuen Player :frowning:


#28

Weil jetzt vermutlich die Zuordnung nicht mehr passt…!?


#29

Ich habe jetzt noch mal nachgeforscht. Im DEV
Beim Adminmenü wird in Zeile 754 folgender Code aufgerufen:

int subMenu = voiceMenu(11, 900, 900, false, false, 0, true);

das voicemenu ruft dann in Zeile 878 die entsprechende Datei auf

mp3.playMp3FolderTrack(startMessage);

startMessage wird mit 900 übergeben
und es wird die Datei mit der Nummer 900 verlangt/abgespielt. Deswegen habe ich den com error 6 erhalten. Sobald ich eine Datei 0900.mp3 ablege, bekomme ich diese vorgespielt.

Im mp3-Ordner scheinen längere Dateinamen doch Probleme zu verursachen. Momentan habe ich nur noch Zahlen als Dateinamen verwendet.

Die Reihenfolge der Dateien kann man sehr schnell mit DriveSort korrigieren (http://www.anerty.net/software/file/DriveSort/). Als Hinweis: In der Eingabeaufforderung werden die Dateien in der Reihenfolge auf dem Medium angezeigt

Ich muss gestehen, dass ich den Code nicht komplett durchblickt habe. Außerdem möchte ich nicht trollen - bei allen anderen scheint es ja zu funktionieren. Ich werde mal auf den neuen Player warten


#30

Das Problem ist ja bekannt. Es scheint manche Player zu geben die nur mit den 3 bzw. 4 stelligen Dateinamen klarkommen. Das steht auch so in der FAQ. Leider können wir nicht :100: genau bestimmen welche Player die Probleme haben. Wenn es nach dem umbenennen geht hast du wohl so ein Exemplar erwischt.


#31

Funktioniert denn damit alles?


#32

Hallo,
ich muss mich erst mal für das Projekt und den Support bedanken.

@Dennis: Die Frage kann ich leider nicht eindeutig beantworten. Ich habe da einige Probleme um das genau nachzuprüfen:

  1. Steige ich bei einigen Zeilen im Code aus, so dass ich nicht immer 100% weiß, welche Datei angefragt wird.
  2. Verstehe ich nicht, warum es bei euch funktioniert - wird wirklich die Datei 900 angefragt, so weiß ich nicht, warum euer Player dann die 316 im mp3-Ordner zieht.

Da ich nicht glaube, dass extra für mich ein Player gefertigt wurde, der sich extrem anders verhält. Befürchte ich ein Layer 8 Problem :slight_smile: Da ihr auch die Makuna DF-Player Bibliothek verwendet weiß ich hier gerade nicht weiter


#33

Ich kann mich irren, aber: Das kann ich dir glaub ich sagen, wir haben die MP3s ausgetauscht als wir auf die DEV Version geswitched sind. Du vermutlich nicht. :wink: In master ist 316 die (ungenutzte) “Admin Funktionen” mp3. In DEV ist das die 900. Kann es also sein, daß du die DEV Version geflashst hast, aber nicht die dazugehörigen MP3s der DEV Version auf die SD Karte kopiert hast? Wenn du Versionen switched musst du immer den advert und den mp3 Ordner komplett austauschen.


#34

Ich weiß nicht ob ich mich freuen oder den Kopf gegen die Wand schlagen soll…
Genau das war es. Doch Layer 8

Vielen Dank für die Unterstützung


#35

Manchmal sieht man halt den Wald vor lauter Bäumen nicht. :wink:


#36

Wieder was gelernt :smile:


#37

IT-ler Humor
:wink:

20zeichen


#38

Sorry, das kommt davon, wenn man zu viel mit Programmierern zusammenarbeitet :slight_smile:


#39

Das klingt so abfällig. Diese Programmierer bauen und supporten den ganzen Kram hier - in der Freizeit. :wink: Bei uns ist Schicht 8 immer der Kunde haha. :wink:


#40

Es ist doch ein Smilie dahinter - und glaube mir, abfällig klingt bei mir anders … Das soll nur heißen, dass ich es öfter im Bug-Tracker lese, das erste Mal habe ich es noch nachgeschlagen und nach einer Woche hatte es sich in meinem Wortschatz manifestiert. Bei uns ist es nicht anders mal ist es der Kunde, mal die QM und ein anderes Mal eben ich :slight_smile: